Development Log: 2021-10-04

2021 October 4

After the most recent entreaty, Amazon SES removed my account from the
sandbox and enabled E-mail access.  I ran a test with
and it reported a non-spam score of 9.9/10, with many of the nits
things only the mail transfer agent can control (for example, DKIM
signing) and properties of the test mail I sent (high link to text

Re-sent the registration E-mail to and it was received
successfully.  Activated the regular user account:
    E-mail:    REDACTED
    User name:  johnwalker
    Full name:  John Walker
    Password:   REDACTED

Changed the administration account to:
    Email:      REDACTED
    Username:   Fourmilab
    Full name:  Shalmaneser
    Password:   REDACTED

Added biography to both accounts.

Made a backup AMI:
    Scanalyst Backup 2021-10-04  ami-0b5b50f2f92e485bf
        /           snap-01a1e8ca182d0d13a
        /server     snap-0d15b164887f4953f

Stopped the existing instance, i-082d04418d82bcfa1, and created a new
instance to remedy errors in configuring the original one.  The
replacement instance is:
    AMI:                Scanalyst Backup 2021-10-04
    Instance ID:        i-0756b0658cac51c9d
    Instance type:      t3.medium
    Availability zone:  eu-central-1b
    Instance details:
        Private IP address:
        Network:    (default)
        Subnet:     subnet-6519951e
        All other: (default)
    Public IPv4 address:
    Public IPv6 address: 2a05:d014:d43:3101:8b80:c858:f08:9bd0
        Root    /dev/xvda   vol-075b7c5e09688d5e6   8 Gb    No delete on termination
        EBS     /dev/sdb    vol-0dd32c02c3bbe7e18   128 Gb  No delete on termination
        Name:   Scanalyst
    Security group: sg-049b61db659446aab     Scanalyst, launch-wizard-2 created 2021-10-02T21:11:21.242+02:00
Selected Launch.  Reused the key pair Scanalyst.pem from the previous

Confirmed that we are now in the eu-central-1b availability zone and
that IPv6 access works correctly.

The Spoiler plug-in works.

The MathJax plug-in, although enabled, doesn't appear to do anything.
Looking at the error log, it's getting:
    TypeError: Cannot read properties of undefined (reading 'inlineBetween')

Changed administrative contacts in the site configuration to:

Had to verify the address through AWS SES before it
could be used as a sender address.  Tested with an E-mail to my
REDACTED address and it worked.

Private messages appear to work, as does E-mail notification of receipt
of a private message when away from the site.