Development Log 2023-10-16

2023 October 16

Removed the "sc2" entry from /etc/hosts on Hayek.  Its IP address is
obsolete anyway after we've stopped and restarted the instance.

If we've given up on using this machine as its own content delivery
server for video, audio, etc. linked on the main Discourse site, due
to the idiotic inability of Discourse to handle URLs containing port
numbers, we should delete the following inbound rules from its
Security Group, sg-049b61db659446aab:
    TCP 591     HTTPS IPv4 Media Server
    TCP 8008    HTTP IPv4 Media Server
For some screwball reason, there appear to be two copies of these rules
in the security group.

We also appear to have some anonymous security groups created
automatically by various AWS goblins which can be dispensed with.

Updated the Route 53 IPv6 AAAA record for to
2a05:d014:d43:3101:d577:c011:85c2:e9db, the IPv6 address of the new
instance.  The main Fourmilab server can now ping6 us on that address.

The browser tab icon in Chrome on the Android tablet showed the default
Discourse icon instead of the Scanalyst mobile icon.  It turns out
that you have to set the Admin/Settings/Branding/manifest icon to the
image you want to appear on Android and this was set to the Discourse
logo out of the box.  I changed it to the mobile icon and now it
displays properly.

Ran a Qualys SSL Labs test:
Results are:
    2a05:d014:d43:3101:d577:c011:85c2:e9db          A+          A+

Renamed instances and volumes to reflect completion of the migration.
    i-0756b0658cac51c9d     Scanalyst (Linux 2 Legacy)
        vol-075b7c5e09688d5e6   Scanalyst L2 root
        vol-0dd32c02c3bbe7e18   Scanalyst L2 server
    i-092217f3135c36549     Scanalyst
        vol-0cf623d818601d186   Scanalyst root
        vol-03cabd4e67ff7ffc8   Scanalyst server

Cleaned up debris from the migration:
    cd /var/discourse/shared/standalone/backups/default
    rm -rf guzz
    rm scanalyst-2023-10-15-190116-v20230926165821.tar.gz
    rm scanalyst-2023-10-15-190116-v20230926165821.tar.gz_ORIG

Made a backup AMI of Scanalyst:
    Scanalyst Backup 2023-10-16 ami-04c0d444c163ec688
        /           snap-0a6bf2f3450405569
        /server     snap-0a7a6e001b4639fdd
This is the first backup since the migration.

Wouldn't you know it?  Less than 24 hours after completing migration
of Scanalyst to Linux 2023, Discourse up and dumps an update, bug fix,
and security update, 3.2.0.beta2, in our laps:
Confusingly, the previous version installed on 2023-09-16 was named
"3.2.0.beta2-dev", so I guess the "-dev" means it's a development
release while this is the real thing.

On the Discourse Upgrade manager page:

I upgraded:
This was the only component that was not up to date.

The update hung about 10 minutes in, after a number of:
messages.  After about 15 minutes, I gave up and pressed "Reset Upgrade"
which issued a scary message.  I told it to go ahead and nothing

I tried to ssh into the machine to see what was going on and ssh hung
trying to connect.  I next tried the AWS local ssh console, which also
hung trying to connect.  Then, after enabling it for my account, I
tried the serial console, which displayed a login message but hung
after I entered a user name.

At this point I initiated a reboot from the AWS Instance console.  It
said the instance was rebooting, but it took around five minutes for
the instance to come up so I could SSH into it.

The Admin/Dashboard page now says we are up to date, running
3.2.0.beta3-dev (huh?), and the Upgrade page says "New Version Available!
which is says is version 3.2.0.beta2.  Now I am completely confused.
Further, the button says "Upgrading...", and when I press it, the
upgrade process log is completely blank.

The makes absolutely no sense.

I decided to kill the container and rebuild it from scratch as I did
yesterday.  This should pull in the latest versions of everything.
    cd ~/discourse/image
    ./launcher stop app
    git pull
    ./launcher rebuild app

After the build was complete and the site came back up, we're right
where we were before.  Admin/Dashboard reports the Installed and
Latest versions as both: 3.2.0.beta3-dev while the Admin/Upgrade
page says the newest version is 3.0.0.beta2.  The button said
"Upgrading", but when I pushed it and then did "Reset Upgrade", which
flipped the button on the upgrade page back to "Upgrade".

This is a total clown show.  I don't think these guys have any idea
what they're doing, and I'm not going to waste any more time on this.
I'll wait until they issue the next major update (Wonder what they'll
call that one?) and see if they've fixed the update process.

The new features documented as being added in 3.2.0.beta2 appear to be
present in this 3.2.0.beta3-dev, whatever that's worth.

Verified that spoilers are still working.

Verified that MathJax is still working.