Development Log 2024-01-09

2024 January 9

Made a mirror backup to Juno.

Made a backup AMI:
    Scanalyst Backup 2024-01-09 ami-055403d5469ed61d9
        /           snap-07eeeedf7ed788c93
        /server     snap-09bb495532d4d398a

Applied all updates.

    dnf check-release-update
    dnf check-update --releasever=2023.3.20240108

    dnf upgrade --releasever=2023.3.20240108

This installed 71 updates, including a new kernel, openssh, and Docker.

The system had been up for 5 days.  I'm not sure what that reboot
on 2024-01-04 at 08:05 was all about.  I certainly didn't do it, since
I was travelling that day.

    cd ~/discourse/image
    ./launcher stop app
    shutdown -r now

The system came up promptly after the reboot.  We are now running on
kernel 6.1.66-93.164.amzn2023.x86_64.

According to "dnf check-release-update" we are now up to date.

On the Discourse Upgrade manager page:

I upgraded:
    docker_manager      (This upgrade must be run first:
                        the other upgrade buttons are
                        disabled until it has been updated.)

With docker_manager updated, I now proceeded to update:
(discourse-math was already up to date.)

When I tried to update Discourse, Blooie!  The update died early in
the process.  I tried running the update again, and it failed
exactly the same way.

    error Command failed with exit code 137.
    info Visit for documentation about this command.
    Docker Manager: FAILED TO UPGRADE

After the second failure, I went to the Admin page (the site was still
running) and it reported we were up to date running 3.2.0.beta5-dev,
which it claimed was the current version.  I'd never heard of that
before: the Upgrade page claimed the new version available was

This isn't the first time we've seen this kind of crap.  Go back and
look at the notes for 2023-10-16 for the last instance.  I reset the
upgrade and then went back and tried rebuilding the site from scratch.
    cd ~/discourse/image
    ./launcher stop app
    git pull
    ./launcher rebuild app
After the rebuild, the Admin page now reports we're running on

Once again, it's a total clown show.  At least it says it's up to date
now, albeit running a version newer than anything we've ever heard of
in any announcement from Discourse.  It's running and it says it's up
to date, so I'm not going to poke this snake any more right now.