Roswell System Narrative


I am currently in the process of bringing up a new principal development machine for Fourmilab, intended to replace the Dell Precision 7710 which has served that function since its installation in March 2017. For the new machine, I chose an M18 R1 configuration from the Alienware division of Dell. While these machines are normally targeted at gamers, they provide large main memory (64 Gb DDR5), a fast central processor (Intel 13980HX, 13th generation, 24 core), a high-end graphics processor (GPU) (NVIDIA GeForce RTX 4090 16GB GDDR6) which is suited for machine learning training and inference as well as graphics, plus plenty of file storage (two 2 Tb PCIe solid-state drives [SSD], configured as a 4 Tb RAID0 array), all in a laptop package with a high quality US-ASCII keyboard and plenty of I/O ports around the outside.

This is the system narrative for this machine, written in the style I have used for all Fourmilab machines for decades, including this site’s Site Development Log. This amounts to a flat text file without fancy formatting or typography, embedded here as HTML <pre> text blocks. Each entry in the log will be a separate comment within this post for the day it describes. When development is particularly fast and furious, I may append to the item for the current day multiple times as events occur.

I do not subject these system narratives to the kind of obsessive proofreading and editing of normal posts and comments. So, things may be somewhat rough-edged. Live with it.

We start with acquisition and initial installation of the system.


2023 June 26

Ordered system: order acknowledgement is in:

                          Dell Alienware m18 R1
                            System Narrative

        13th Gen Intel(R) Core(TM) i9 13980HX (24-Core, 36MB L3
        Cache, up to 5.6GHz Max Turbo Frequency)
    Video card
        NVIDIA GeForce RTX 4090 16GB GDDR6
    LCD panel
        18" QHD+ (2560 x 1600) 165Hz, 3ms, ComfortView Plus, NVIDIA
        G-SYNC + DDS, 100% DCI-P3, FHD IR Camera
        64GB, 2x 32GB, DDR5 4800MHz
    Hard drive (SSD)
        4TB (2x 2TB PCIe NVMe M.2 SSD)
        Intel(R) Killer(TM) Wi-Fi 6E AX1690i, 2x2, 802.11ax, MU-MIMO,
        Bluetooth(R) wireless card
        Alienware CherryMX ultra low-profile mechanical laptop keyboard
        with per-key AlienFX lighting - US English
    AC adapter
        330W Small Form Factor adapter

        Dell Adapter - USB-C to HDMI/ DisplayPort with Power Delivery
        Dell external USB DVD+/- RW Drive- DW316

2023 July 20

System received: delivery confirmation is in:

The Linux driver to allow user programs to control lighting effects via
the USB driver.
the device compatibility list is in:

2023 September 16

Un-boxed and went through initial set-up.

Service tag is 54GSGX3
Express Service Code 11153978535
Manufacture Date 07/08/2023
Ownership Date 09/16/2023
BIOS revision 1.10.1

Configured (required) Microsoft account via Skype log-in:
    Name:       fourmilab
    E-mail:     REDACTED
    Password:   REDACTED

Set up system PIN as REDACTED.  This is moronically demanded every time
the screen comes out of inactivity lock.

Attached the Logitech wireless mouse to the USB port on the back panel.
It just worked.  The touch pad is still enabled with the mouse plugged

2023 September 17

Began the procedure of "upgrading" to Windows 11 Pro in order to try to
install Hyper-V and support Xubuntu running under hypervisor.  Instructions
are in:

Go to Start/Settings/System/Activation:
    This confirms we're running Windows 11 Home and that it's activated.
    It reports a Product ID of 00342-21086-81813-AAOEM and
    Product Key of XXXXX-XXXXX-XXXXX-XXXXX-6VJ48.  Imagine how
    improbable it is to get a product key with all of those X's!

    Click "Upgrade your edition of Windows", then "Open Store" in the
    drop-down, to the right of "Upgrade in the Microsoft app".

    "Microsoft Store" window pops up, which displays:
        Try that again
        Something happened on our end.  Waiting a bit might help.
    Welcome to Microsoft!

    Trying again after several minutes got the same result.

    Clicked Home in store window and tried to log in to store.  This
    requested the PIN and then asked for an E-mail address.  I gave it, the same as on the Skype account I used to register the
    machine.  Unchecked the "Spam me with crap" box.

    It rejected the E-mail, saying "REDACTED is already a
    Microsoft account.  Please try a different email address.
    Tried REDACTED.

    That failed with:
        There's a temporary problem with the service.  Please try
        again.  If you continue to get this message, try again later.

    Failed again.

    Restarted log-in process.  This time, with the same PIN, it skipped
    the "Enter E-mail" screen and popped up a screen to verify the
    existing REDACTED E-mail, to which it said it had sent a
    security code.  Entered the 6 digit security code from the E-mail.
    After a long pause (all of this made much more confusing since the
    buttons in these pop-up dialogues give no visual confirmation that
    they have been pressed), it appears to have logged me on.

    Now tried the Open Store button in the Activation window.  It
    immediately popped up the "Try that again" message in the Store
    window, to which I am now logged in.

    From Home, tried searching for "Windows 11 Pro" and got hundreds of
    items (actually, it doesn't give a count, so it may have been
    thousands) with what I was looking for nowhere in sight.  Tried
    "Windows 11 Pro Upgrade" with the same result.  Narrowed the search
    to Apps with no improvement.

Even though I'm hoping to get rid of Windows Home as soon as this festival
of incompetence allows me, this incessant locking of the screen and
making me re-enter the PIN is getting to me.  After searching for a
while in Settings, I found a page "Accounts -> Sign-in options", which
lists four options including "PIN (Windows Hello)".  When you drop down
that option, the "Remove this sign-in option" button is disabled.  So
that doesn't let you turn off the PIN unless, presumably, you enable one
of the even more stupid options.

Lower on the page, there's an item:
    Additional settings
        If you've been away, when should Windows require you to sign
        in again?
This can be set to "Never".  Will this get rid of the idiot PIN lock?
We shall see.

It won't let me change the PIN to anything less than 4 digits, and it
rejects a PIN such as "8888".

If you do a Web search for "buy Windows 11 pro product key", the first
hit is on, which lists:
from Microsoft, "Ships from Services LLC", as:
    Windows 11 Pro Upgrade, from Windows 11 Home (Digital Download)
This is labeled:
    This product is non-returnable and non-refundable.
    Note: Currently, this item is available only to customers located
    in the United States.
Reviews on Amazon give this product 3.9/5 stars, with 23% 1 star
reviews reporting typical Microsoft-style problems and disasters.

The second hit in the search is, which wants to sell
you a full version of Windows 11 for download at US$ 199.99.  There
is no upgrade from Home on this page.

Eight hours later, the Upgrade in Store button still says "Try that
again".  For today, I admit defeat.

You can find the raw keyboard input device with:
    find /dev|grep input|grep kbd
To dump keyboard events as they occur, use (example device name from
    cat /dev/input/by-path/platform-i8042-serio-0-event-kbd | xd
1 Like

2023 September 18

Well, surprise, surprise, surprise.  After having been idle overnight
with the lid closed, when I opened up the machine, it wanted the
idiot PIN, regardless of my having set the idle sign-in to "Never"
yesterday.  Such is the meaning of Never in Microsoft land.

Plus, a window popped up saying I had not "set up" "Microsoft Hello".
I cancelled it.  What I really want at this point is "Microsoft Goodbye".

The Settings/System/Activation window I had open spontaneously closed
itself overnight.  I opened it back up again and tried the Upgrade to
Pro via "Open Store" again.  It's now around 24 hours after the first
try and the result was the "Try that again" screen, once more informing
us "Something happened on our end."  I could have figured that out all
by myself.  And "Waiting a bit might help."  On the other hand, it might
not and probably won't.  It looks like this "Upgrade" mechanism is a
cruel hoax. There is a "Report this problem" button.  Pressing it
summons a pop-up asking if we wish to depart Microsoft Store for
Feedback Hub.  Click Yes.  This wants us to "Sign in to use Feedback
Hub".  Click "Sign In" (the only option).  This prompts to sign into
the account to which I am already signed in at log-in time.

Then there's a big Welcome pop-up that tells us to "Use the Feedback
Hub to tell us which features you love or when a feature could be
better."  What, no mockery of cruel jokes and abuse of paying customers?
What kind of Feedback is this?  Clicked OK (only option).  From there
on it's deep into cutsie-pie bullshit.  I cancelled the window.

All right, you win (or lose, as it were), Microsoft.  Let's try buying
the upgrade and product key from Amazon.  Signed into my U.S. address
Amazon account using the Edge "Web browser" and navigated to the Amazon
link in yesterday's epistle.  Added to cart (US$ 99.99) and proceeded
to checkout.  Dismissed unsolicited pop-up with Microsoft Edge offering
"Coupons" from various corporate grifters.

When I select the credit card I always use with this account, it pops
up a box asking me to verify the credit card with a text box that
doesn't indicate what I should enter.  I eventually divine it wants me
to enter the complete 16-digit credit card number, which it accepts.
I then confirm selecting this account and it moves on to "Place your
order".  (None of this happens when I use this Amazon account and card
on two Linux systems or an Android tablet.)

Take a deep breath and click "Place your order".  A new screen pops up
with "Access your content".  Now, have been warned you can only
download it once so, as the hydraulic press guy says, having just
poured 109.09 BidenBucks down the rat hole, "And here we go...".

This goes to a "Your Orders" screen showing the item with a bunch
of buttons.  To get here' O had to first dismiss an Edge pop-up asking
if I wanted it to track my orders.  No thank you.  The only promising
button on this page is "Go to Your Software Library".  Clicked it.

This shows another page with the following:
    Product Key: REDACTED
There is a link "How to redeem this item".  Clicking it brings up a
page which simply says enter the product key in the Activation
Settings page, then click Next, then Start.

So, it's off to Start/Settings/Activation/Upgrade your edition of
Windows/Change product key/Change, paste product key in text box,
and click Next.  This summons an "Upgrade your edition of Windows"
pop-up warning it "might take a while and this device will restart".
Clicked Start.  A progress box pops up.

This only takes about a minute, informing us this is basically just a
software switch, not a genuinely different system.  It then starts a
reboot (because Microsoft), and says it's "Installing features", which
again takes only a minute and does another reboot in the middle.  Now
it comes back up to the lock screen and demands the PIN again.  Then a
series of "Peekaboo" pop-ups come and go saying the "Upgrade" was
successful and some bullshit about protecting my OneDrive account
(whatever that might be).  Finally, it settles down into an idle screen.

Start/System/Activation now shows "Windows 11 Pro" and the new Product
Key.  The Product ID has changed to:

Downloaded the Xubuntu 22.04 release ISO from:
into the Downloads folder on my Windows account.  This takes around 50
minutes on the Bleakleigh DSL.  Windows 11 out of the box, of course,
has no idea what to do with a Torrent file.  The SHA256 for this
download is:
    eec14c4e6f13120555fee0f1f3c1909bd8196a48de4012b6ea96fb7dd27a5aab *xubuntu-22.04.3-desktop-amd64.iso

When I plug in the 128 Gb VFAT USB stick that I use without any problems
everywhere else to transfer some files, Windows complains "There is a
problem" and wants to "Scan and repair it".  No thanks.  I escaped that
and opened it in the file viewer and everything appeared to be fine.
Transferred wallpaper files and installed one to replace the factory

Installed the base Cygwin installation from:
I installed it in the default of:
not knowing the horrors which may eventuate should I choose another
location.  Chose to download from mirror at:
Selected Default packages to install.  Allowed it to add icon to
desktop and start menu.

With Cygwin installed, my home directory C:\Users\fourm (it appears to
have made up the user name from the Skype account used to register the
product code) is mapped to:

Now I am able to verify the sha256sum of the Xubuntu ISO download.  It
is good.

The "fourm" account is hard linked to the Microsoft account (created
from the Skype account) used to register the machine.  That (stupid)
name cannot be changed.  It is an administrator account.  I decided
to treat it like the "Installation" account I create when performing
a bare-metal Linux install and create a separate, non-administrator,
"kelvin" account for regular work.  I proceeded as follows:
    Start/Settings/Accounts/Other Users
        Click "Add account"
This sends you down a rabbit hole of trying to get you to specify a
Microsoft account for the new user.  After declining to specify an
E-mail address or mobile phone number, you get to a "Create account"
page which has an item at the bottom, "Add a user without a Microsoft
account".  Clicked it.

Now you get a "Create a user for this PC" page, which asks for a user
name and password.  Created "kelvin" with no password.  This created
a "Standard user" account (as opposed to administrator), which I
left that way.

Now you can switch user by Start then click on your user name.  It will
show the other user names on the computer.  Click the user you added,
and it shows a Sign In page which, when you click on it, starts a build
account process which it says may take "minutes" but only takes around
15 seconds.  Then the new user gets to disable all of the spam and
spyware options ("privacy settings") for this account which are, of
course, enabled by default.

To allow the new user access to the original user's files, you have to
try to access their home directory, whereupon a security pop-up appears
which requires entering the idiot PIN again.  After that, it's
supposedly enabled forever.  We'll see.

After all of this, the new user can get to their home directory under
Cygwin as:

Configuring Edge under the new account requires another whole pass
through disabling spam and spyware.  I imported settings from my Google
Chrome account which is supposed to remember bookmarks, passwords, etc.
if I can ever figure out where they are hiding.

Oh, I see.  After about ten minutes, a pop-up appears saying the import
of data from Google failed.  This has a "Try again" button which, when
you press it, pops up an entirely different import dialogue.  I select
to import everything (the default) and click start, and now have an
"Import in progress" display with a Fidget Spinner of Patience going
around and around.

After ten more minutes, the Google Chrome import failed again with
"Couldn't import your data".  So, another cruel joke.  Clicked the
"Got it" button to escape this pothole.


Now we begin the process of enabling Hyper-V to install Xubuntu as a
virtual machine under the benign tutelage of Microsoft Windows.  Our
guide to this is the Windows Central document "How to run any Linux
distro alongside Windows 11":
in particular the section "How to Run Linux with VM on Windows 11" and
then "Create Linux virtual machine (manually)", which describes how to
install an arbitrary Linux environment from an ISO file (as we've
already downloaded).  For all of the following, I logged out of the
user account and logged back into the "fourm" Administrator account
which, of course, required the idiot PIN.

Microsoft's official guide to getting started with Hyper-V is
"Step-By-Step: Enabling Hyper-V for Use on Windows 11":
dated 2023-02-22.  This does not impress when, in Step 1, it tells you
to run a program called "msinfo32" to check if your system is compatible
with Hyper-V (why not "msinfo64", since Microsoft have dropped support
for 32-bit platforms?), then tells you to look for a section called
"Hyper-V Requirements" under "System Summary".  No such section exists.

We start enabling Hyper-V.  Go to Settings/Apps/Optional Features.  This
shows a page which has, at the bottom, a "Related settings" section
where you click "More Windows features".

This pops up an old-style Windows dialogue box with a menagerie of
features, including Hyper-V, which expands into Management Tools and
Platform beneath the main box.  Checking the main box checks both of

Click OK, and it goes off to progress bars for "Searching for files"
and "Installing", and then it (surprise!) says it needs to reboot again.
(This time is says "reboot", not "restart", but the button you need to
click says "Restart now"  I click it.

This shows an "Updates are underway" screen and a patience spinner,
which goes for about a minute.  After that, it reboots, says "Customizing
features", and goes back to the lock screen, requiring the PIN again.
Navigating back to the big box of features shows Hyper-V now enabled.

Now, from the Start Menu thing (which looks like a blue square with
crosshairs through it), you can search for Hyper-V (which doesn't show
up as either a Pinned item or in "All apps" but, nonetheless, appears
as "Hyper-V Manager" when you use the search box.  Click it to launch
the manager.

When the Hyper-V Manager window appears, you have to first connect to
a virtualisation server under the Action menu.  This is never
mentioned in the documents linked above, which assume you have already
done this.  Select connect to server and then select server on the
local machine rather than a remote server.  Now, finally, the options
in the documents shown on the Action menu appear and may be clicked.

Under Action, select New/Virtual Machine.  This pops up the "New Virtual
Machine Wizard" (I knew, sooner or later, it was going to come to
Wizards again).  We now, going through the steps, specify:
    Specify Name and Location
        Name:   Roswell
        Location:   C:\ProgramData\Microsoft\Windows\Hyper-V  (default)
    Specify Generation
        Generation 1  (default)
            (Ubuntu 14.04 and later are supposed to support Generation
            2, but why live dangerously?)
    Assign Memory  (default)
        Startup memory: 4096 MB
        X Use Dynamic Memory for this Virtual Machine
    Configure Networking
        Default Switch  (this is not the default, which is Not Connected)
    Connect Virtual Hard Disk
        Name:   Roswell.vhdx
        Location:   C:\ProgramData\Microsoft\Windows\Virtual Hard Disks\
        Size:   2048 GB
    Installation Options
        Install an operating system from a bootable CD/DVD-ROM
        X Image file (.iso): Downloads\xubuntu-22.04.3-desktop-amd64
        (Review configuration)
Finally, click Finish, and away we go.

After a disturbingly short time, a new item, "Roswell", appears under
Virtual Machines, in state "Off".

Now, it's time for the Big Gulp.  Select the Virtual Machine name,
click Start in the panel at the right, then click Connect there.  A
Virtual Machine Connection window pops up.

In this window, the Xubuntu Install pops up.  Click "Install Xubuntu".
    Keyboard:   English (US)
    Normal Installation
    Download updates while installing Xubuntu
    X Install third-party software for graphics and Wi-Fi hardware and
      additional media formats.
    X Erase disk and install Xubuntu.
Click "Install Now".  Confirm Continue after scary partition formatting
    Time zone:  Isle of Man
Specified initial identities:
    Your name:  Installation
    Computer name:  Roswell-U
    Username: installation
    Password: regular user password
    X Require password to log in

Installation is complete.  You need to restart....  Clicked "Restart Now".

After clicking Restart, it goes through the text mode shutdown sequence,
then displays the Xubuntu black background logo.

For a *very* long time.  A very, very long time.  After a while what
appears to be a single white dot cursor responding to the mouse appears.

After about 10 minutes, gave up and pressed Reset on the Virtual Machine
Connection window.  It went through a boot process and popped up
Installation log-in window.

After a long pause, the virtual machine had lost connection to the mouse
and keyboard.  I reset the virtual machine and after logging back in as
Installation, it was working again.

It now appears every time the host Windows system goes into screen saver,
the virtual machine loses connection to the mouse and keyboard.  The
only way I've found to restore the connection is to reboot the virtual

Sound output does not work.  This looks ugly.  I will defer until

Given that you function in computer land at stratospheric levels compared to me - in the basement, I wonder if you can sympathize with someone like me, a mere user, merely trying to do simple things. I cannot count how many times every one of my devices has barely escaped being thrown, as hard as possible in order for maximum therapeutic effect, against the wall. And, something doesn’t work almost daily.


This report has caused me to pat myself on the back for deciding, about ten years ago, to run Linux on bare metal and Windows in VMs. Always and everywhere. I have WindowsXP, Windows7, and Windows10 VMs available on short notice, and older DOS and Windows are possible with my archive of install media. Time required to move a VM from one relatively permanent home to a new relatively permanent home is about five minutes more than the time required to dd the disk image to the new box. Without Windows knowing that it lives somewhere new.


I had decided to try running Windows 11 as the host and Xubuntu under Hyper-V because I figured that was most likely to allow Windows native support to the GPU and CPU features plus networking and sound. Looks like Hyper-X is more hype than hyper and the kind of cruel joke one expects from Microsoft.

What VM do you run under Linux to host Windows in VMs? Does it provide Windows full access to GPU, sound, screen size, USB peripherals, camera, and networking? Does it support expandable virtual file storage?

1 Like

2023 September 19

    glxinfo -B
to query graphics information.  It says:
    Vendor: Mesa (0xffffffff)
    Accelerated: No
So it looks like Hyper-V does not provide pass-through access to the
GPU.  The graphics configuration provided is a 1024x768 generic VGA.

    ls -ltrh /dev/video*
So it looks like Hyper-V does not provide pass-through access to the

    sudo su
    arecord -l
Reports "no soundcards found".  So Hyper-V does not provide pass-through
access to the microphone.

OK, it looks like Hyper-V is a write-off, another Microsoft cruel joke.
Let's set it aside and try some things on native Windows.

Installed Phoenix Firestorm viewer for Second Life.  After some fiddling
with settings, it seems to be working, including voice input and
output.  There was a scary pop-up about enabling voice access through
the firewall required to use voice.  I enabled it for private and
public networks and it seems to be working OK.

Installed Skype from the Microsoft Store.  Amusingly, it has a rating
of 2.6/5 stars, indicating, I suppose, that Microsoft has worked their
magic on it.  This is a 133 Mb download: Heaven knows why (or perhaps
Hell would know better).  It configured itself to use the Microsoft
account I set up when installing the machine which was, after all,
derived from a Skype account.  I made a test call and it appeared to
work OK.  The Skype camera test (click on user name icon, then
Settings, then Audio & Video) seems to work OK with the Integrated

Installed Zoom from Microsoft Store.  After approving access through
firewall (as for Skype), the camera, earphones, and microphone seemed
to work OK.

OK, we've had about enough of Hyper-V: more than enough to decide it's
worthless.  Deleted the ROSWELL virtual machine, then went back to
Settings/Apps/Optional Features.  This shows a page which has, at the
bottom, a "Related settings" section where you click "More Windows
features".  In that box, unchecked Hyper-V and applied the change.  It
spent a few seconds twiddling files (one hopes, deleting all the crap
it installed when I turned it on), and then wants me to reboot.  Away
we go.

Downloaded VMware Workstation 17.0.2 Player for Windows 64-bit from:
This is a 577 Mb download.

Tried to install.  Even though Hyper-V is uninstalled, it wants me to
install something called Windows Hypervisor Platform, which is says is
only needed if Hyper-V is installed.  This is installed in the same place
as Hyper-V (see above) and, of course, required a reboot after you
enable it.

On the third attempt, got into the install proper of VMware.  Enabled
the "Enhanced Keyboard Driver", whatever that is.  VMware installation
completed and, you guessed it, requires a reboot.

Started Xubuntu installation.  I gave it 2 Tb file storage, 16 CPU cores,
and 32 Mb RAM.  Used the same ISO as before with Hyper-V.  It's crunching
through the installation as I have to leave for a while.  I'll see what
became of it when I return.


With VMware, you can switch the VM window to full screen and the VM
sees the entire screen as its window, propagating this to the window
manager.  "glxinfo -B" reports a smarter graphics configuration, but
still no acceleration, indicating the VM does not have access to the

There is no /dev/video*, indicating the VM cannot access the camera.

At least with VMware the VM does not regularly lose access to the
mouse and keyboard, requiring a reboot.

VMware is a tremendous improvement over Hyper-V, but it still seems
to come up short in terms of full access to the underlying hardware, in
particular the GPU.  At this point it looks like where I'm heading is
dual boot into either Windows 11 or Xubuntu Linux, running on the bare
metal with their own partition on the big SSD array.



Standard built-in LInux KVM managed by libvirtd and virt-manager, virt-viewer UI most of the time.

No, not really. Though there are PCIe passthrough options that many use with GPUs other than the primary display. (Though the one academic I know that uses NVidia compute GPUs for emag number-crunching runs it all in native Linux.)

Pretty much. Although I tend to use Linux networking (far superior feature set) to do any complex stuff and push a bridge interface into the Windows world.

FWIW, on my bare metal host:

$ glxinfo -B
name of display: :0
display: :0  screen: 0
direct rendering: Yes
Memory info (GL_NVX_gpu_memory_info):
    Dedicated video memory: 8192 MB
    Total available memory: 8192 MB
    Currently available dedicated video memory: 7037 MB
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: NVIDIA GeForce RTX 2070 with Max-Q Design/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 525.125.06
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.6.0 NVIDIA 525.125.06
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)

OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 525.125.06
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20

On an older XFCE VM (the only one where I’ve set up graphics), I get this:

$ glxinfo -B
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: VMware, Inc. (0xffffffff)
    Device: llvmpipe (LLVM 6.0, 256 bits) (0xffffffff)
    Version: 18.0.5
    Accelerated: no
    Video memory: 1903MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 3.3
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.0
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 6.0, 256 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 18.0.5
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.0 Mesa 18.0.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.0 Mesa 18.0.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00

Note that virt-viewer let me cut and paste directly from the VM’s terminal within the graphical desktop to this comment editor in Firefox on my bare metal host. (I do similar copy-and-paste with my Windows VMs all the time.)


2023 September 20

To try to get audio output from Xubuntu under VMware working, according
went to Settings/Sound/All sound devices/Properties/Stereo Mix/General/Audio
and set "Allow apps and Windows to use this device for audio" to Allow
(default is Don't allow).  On this page there's a "Test your microphone"
item.  It doesn't seem to do anything.

Now audio output and the microphone seem to be working in VMware.

In the Linux VM:
    sudo su
    snap install audacity

The keyboard mapping was screwed up under Windows 11.  I set the keyboard
to "English (US)", which is supposed to be what I ordered (and appears
to be what I got from the keycaps), but many of the outlying special
characters are wrong.  There doesn't appear to be any way to select the
variant layout by number of keys.  However, switching the keyboard from
English (UK) and back to English (US) appears to have fixed it.  Oddly,
the keyboard mapping in Linux under VMware was completely correct.

Began the process of setting up to dual boot Windows 11 and Xubuntu
following the instructions of:

Downloaded Rufus on Windows 11:

Used Rufus to create bootable USB stick with the Xubuntu ISO downloaded
for the virtual machine adventures.  This is a 32 Gb USB stick previously
formatted VFAT to transfer medical records,  Making the bootable ISO
wipes anything on the stick.  Configured for GPT partition scheme and UEFI
(non CSM) target system.  The drive is formatted FAT32 with 16 Kb
cluster size (both default).

Shut down the Xubuntu virtual machine.

Rebooted into BIOS by hammering F12 during restart process.

To boot from USB drive, insert USB drive, then go to System/Recovery
and under Advanced startup, click Restart now.  This starts a reboot
then displays a "Choose an option" blue screen, where you can select
"Use a device".  Select "UEFI Kingston DataTraveler 150".  This resets
and displays the GRUB boot screen.  Select "Try or Install Ubuntu".
If you aren't fast (or are writing this log), it will auto-select after
some number of seconds: another peekaboo screen.

Click "Try Xubuntu" to test hardware compatibility.

Connected to WiFi with usual password via Network button at upper right
of title bar on screen.

Sound and microphone seem to work.

Installed "cheese" to test video camera:
    sudo su
    apt-get update
    apt-get install cheese
Camera appears to be working.

Now, glxinfo -B reports graphics accelerated.

    apt-get install audacity
and confirmed audio recording and playback is working OK.

Installed Google Chrome and tried several Chrome Experiments to test
GPU acceleration.  It appears to be working.

Here is a guide to GPU stress tests for Linux:

To further test GPU access:
    sudo su
    apt-get install glmark2
The test logs FPS in the console window while running.

Downloaded the Unigine Valley benchmark from:
The benchmark reports:
    FPS:        14.7
    Score:      615
    Min FPS:    10.2
    Max FPS:    23.0

All right, it looks like we're ready to go.  Clicked the "Install
Xubuntu" icon on the desktop to start the for-keeps installation.

    Language:           English
    Keyboard layout:    English (US)
    Install third-party: Checked
    Secure boot:        Disabled

When it finally gets to Installation type, it says:
    The computer currently has no detected operating systems.
and offers only the option to completely wipe the disc and install.
There is no option to install alongside Windows Boot Manager.

Well, that's no good.  Let's quit and try rebooting and then proceeding
directly to install without the Try Ubuntu step.

Rebooting to Recovery mode didn't see the USB stick.  You have to reboot
into Windows 11, then insert the stick and wait for its directory to
pop up, then finally initiate the Recovery boot from it.

This time, it says that configuring 3rd party drivers requires setting
a UEFI password.  Used the conventional server root password.

Once again, we get the "no detected operating system" message.  Perhaps
the Xubuntu installer doesn't know how to find the operating system on
the BIOS-supported RAID drive.  Beats me.

And with that, I'm beaten, at least for the night.  I guess the next
step is to proceed with an old-style shrink, repartition, and set up
a boot manager style dual boot.  Let's party like it's 1999.
1 Like

If you’re having a difficult time with this how would the average person fare?

1 Like

Windows 10 and 11 have made it increasingly difficult to dual-boot, with their EFI management handled from within Windows. The EFI BIOS boot management normal functionality seems to be emasculated in the presence of modern Windows.

But, I must admit that I’ve only toyed with this occasionally. Like the last laptop I bought for my wife. I toyed with Win11 home for a couple hours before I wiped completely and installed Kubuntu. (My wife’s only need for Windows is for her work, who provide their own laptop, and for which I offer no assistance. Zero.)


Based on further investigation after closing out today’s log, it appears that the problem Linux is having in recognising the existing Windows installation is that it is completely unaware of the RAID0 array which is managed by the Intel RAID code in the BIOS. It sees only the two SSDs that make up the array as separate drives and doesn’t find a partition table on either one, as it is apparent only when you access the pair as a striped RAID0 array.

What it looks like I’ll have to do is delete the RAID array and then do a bare metal install of Windows 11 on the first SSD. I was hoping to avoid this, since this means I’ll have to then re-install the Alienware third party stuff which is pre-installed on the system. Then I can install Linux on the second SSD and have its GRUB configured to allow booting from either SSD.

Whether any of this works or is simply walking into another room full of trap doors will be chronicled in the log as it happens. Linux claims to play nice with Windows UEFI boot. We shall see…


I had to laugh – because that sounds so familiar. As Bill Clinton would have said, I feel your pain!


2023 September 21

After further reflexion, it appears that the problem Linux is having in
recognising the existing Windows installation is that it is completely
unaware of the RAID0 array which is managed by the Intel RAID code in
the BIOS. It sees only the two SSDs that make up the array as separate
drives and doesn’t find a partition table on either one, as it is
apparent only when you access the pair as a striped RAID0 array.

What it looks like I’ll have to do is delete the RAID array and then do
a bare metal install of Windows 11 on the first SSD. I was hoping to
avoid this, since this means I’ll have to then re-install the Alienware
third party stuff which is pre-installed on the system. Then I can
install Linux on the second SSD and have its GRUB configured to allow
booting from either SSD.

Let's start by shrinking the Windows 11 partition on the RAID array
down so it will fit onto one of the 2 Tb drives.  This should, I hope,
allow it to be saved as an image backup on an external hard drive and
then restored onto the first 2 Tb drive after the RAID array is broken
up.  According to the documentation for image backups, you can only
restore to a drive of the same or larger size.  This is what requires
the shrink before we save the mirror image.

To shrink the Windows 11 partition, launch the Start/Disk Management
application.  Right click the "OS (C:)" partition in the Disk 0 status
bar and select "Shrink Volume...".  This follows instructions in:
the "Shrink partition for new setup".

The Shrink pop-up reports:
    Total size before shrink in MB:         3882430
    Size of available shrink space in MB:   3690324
    Total size after shrink in MB:           192106
    Enter the amount of space to shrink in MB: 2700000
    Total size after shrink in MB:          1182430
which should fit comfortably on one 2 Tb drive with the other

Clicked Shrink.  This was almost instantaneous, and now shows:
    OS (C:) 1154.72 GB NTFS
    2636.72 GB Unallocated

Plugged in a 3 Tb backup drive last used in December 2021 to a USB port
and powered up.  Now we need to re-format as NTFS to accept the backup.
Instructions are from:
Open File Explorer from the taskbar.  Click "This PC".  And...the drive
does not appear, showing only OS (C:).  Unplugged and re-plugged USB
cable, and the system chimes when you do this, but it still doesn't

However, the external drive shows up in the Disk Management window as
"Disk 1", 2794.49 GB Healthy (Primary Partition).

In the Disk Management window, deleted the partition on Disk 1.  Now
it shows two partitions:
    2048.0 GB Unallocated
    746.49 GB Unallocated
Now, I right click on the left Unallocated box and select "New Simple
Volume...", summoning a "Wizard" (or course).  Select maximum size
and choose not to assign a drive letter.  Format as:
    File system:            NTFS
    Allocation unit size:   Default
    Volume label:           Mirror 2023-09-21
    Quick format:           Unchecked
Click Finish and it starts beavering away.

The rate the formatting was proceeding indicated it would take "almost
forever".  I cancelled it.  Then I discovered that if I right clicked
on the Disk 1 box at the left, I had the option to "Convert to GPT
Disk".  This is the fancy new partitioning system all the cool kids are
using now, and selecting that eliminated the two spaces on the disc
(presumably because the legacy MBR scheme cannot address a space larger
than 2 TB, and now shows a single unallocated space of 2794.47 GB.

I clicked that space and started a new format of it, as above, but
this time with quick format enabled.  This completed in a few seconds.
The drive does not show up in This PC, even after unplugging it and
plugging it back in.

Now we proceed to making a mirror backup.  Go to Control Panel/System
and Security/Backup and Restore (Windows 7).  In the left panel,
click "Create a system image".  It says "Looking for backup drives"
and after around 30 seconds, gives up having found nothing.  It
shows nothing under "On a hard disk".

Go back to the Disk Management window, right click the partition on the
Mirror 2023-09-21 drive, and choose "Change Drive Letter and Paths".
I assigned it drive letter G.

Now is shows up in This PC as G:. shows up in the "Create
a system image" panel when I "".  Select it and press Next.
Next, we get "Confirm your backup settings", indicating it will use
162 GB of space on drive G and back up:
    EFI System Partition
    OS (C:) (System)
    WINRETOOLS (System)
Click "Start backup".

It won't create a "System repair disc" on a USB stick of external drive.
It will only write a DVD, and when you try to give it a CD-R, it
rejects it saying 700 Mb isn't enough space.  I don't have a DVD-R,
so I'm going to live dangerously and skip this step.

I don't see any way to eject the external USB hard drive as you'd do
with a USB stick, so I set it Offline in "Disk Management" before
unplugging it and powering it down.  I hope I don't regret that

To get to RAID configuration, monkey-hammer on F12 during restart, and
when you get to fancy pre-boot screen, select "Device Configuration".
This goes to a text mode screen like the old F2 days.  Select "Intel(R)
Rapid Storage Technology" (RST) and press Return.  This shows your RAID
volumes.  Select the volume and press Return.

This shows you information about the array.  At this point, you have
under Volume Actions, Delete.  Click it.  A Delete screen appears
which warns us all data will be lost.  Select Yes.

Now we go back to the RST screen, which shows two "Non-RAID Physical
    PCIe 0.0
    PCIe 1.0
You can highlight these to show details.  Each shows 1.8 Tb available.

After separating the RAID array into its component discs, the system
was non-bootable.  At this point, you're supposed to be able to
recover from the BIOS ROM, booting over HTTP into a restore program.
Despite successfully connecting to WiFi, this predictably fails with
"Cannot find IP address".  So, at this point, we have no Windows
UEFI boot source to restore the Windows system far enough to reload
the mirror backup we made.

But I do have the UEFI Xubuntu Linux USB stick.  I plug it in and now
I can boot into its installer.  Choosing the second SSD (PCIe 1.0),
I partition it into an EFI partition and an EXT4 single-partition
files space and do a full install of Xubuntu onto the second SSD,
placing the boot loader on the first SSD.  After the install process,
the system boots directly into Xubuntu from the second SSD.

Started download of Windows 11 all versions ISO from:
This is a 5.4 Gb download, and takes a while.

Created a bootable Windows 11 install USB stick according to:
Installed WoeUSB via the PPA and apt install pathway.

Removed Windows installation USB stick and verified Xubuntu reboots on
a full restart.

Inserted Windows installation USB stick.  It opened as an ISO in

Rebooted and did the F12 Skinner rat trick.  Now it came up and showed
me the Windows USB stick as a boot option.  Clicked it, and here we
are in the Windows installation start page!

Selected English (United States) as language, locale, and keyboard.

Accepted licence.

Chose Custom Install

Changed BIOS settings to disable RAID on and set SATA/NVMe Operation to

In order for Windows to find the drives after disabling RAID, you have
to set SATA/NVMe operation to AVHCI/NVMe.  Disabled hides the drives.

Rebuilt Windows USB stick in NTFS mode.  This apparently allows it to
show up in the boot menu after disabling RAID.  I have no idea why this

Selected to install Windows 11 on Drive 1, Unallocated Space, 1907.7 GB.

After installing Windows 11 on the drive, it reboots and runs normally.
However, we have no WiFi, no sound drivers, no nothing.  This is a
purely generic install.  So, I think, great!  Now all we have to do
is restore the mirror backup made at the start of this very long day
and we're back in business.

After another couple of hours of trying this and trying that and trying
the other thing, it is now evident the mirror backup is a cruel joke.
Every time you try to restore it, it fails within seconds saying there
is no suitable disc on which to install it.  This, notwithstanding there
is a disc with 2 Tb of available space and nothing else on it just
waiting to receive the backup.  The "Details" message is a half page
of Microsoft bullshit suggesting everything as a possible cause
including but not limited to what you had for dinner, but offering no
concrete steps to remedy the problem.

So, we try A, B, and C, then A and B, then A and C, then B and C,
and...give up.  As I said, cruel joke.  I wonder how many people
have these mirror backups sitting on their shelves as the ultimate
rescue from a ransomware attack and haven't ever tried restoring
them to see if they actually work.  Hey, they think, it's Microsoft:
how bad can it be?

Next course correction: try the Dell/Alienware Operating System Recovery
Now, this only works if you first have a running Windows 11, so you need
to get Windows 11 up somehow before starting, unless you have it also on
another machine (and may God have mercy on your soul).  Well, we have
Windows 11 staggering, if not running, so I downloaded it and, it having
detected my service tag and deduced my configuration, gave it the 128
Gb USB stick I used for the Windows recovery USB (I don't have these
things coming out of my ears, so I have to re-use), and it spent around
30 minutes downloading stuff and putting it on the USB stick, at which
point it told me to reboot.  I did so, and it came up in an Alienware
branded restore program booted from the USB stick.

The first step is to scan the hardware for problems, which takes around
15 minutes, half of which is a RAM test.  Fair enough, we have 64 GB of
RAM to test.  The memory test really gets the fan going.  This is the
first time I've appreciated Alienware as space heater.  Hardware scan
completed with no errors.

Proceeded to Reset, which does a full factory reset of the operating
system.  This requires an Internet connection and is estimated to run
between 40 and 45 minutes.  Install will be of Build 10.0.22621.1848.
Started at 22:20 UTC.  Chose not to transfer settings and data, as we
are loading onto a virgin Windows 11 install.

Selected first SSD, containing virgin Windows 11 install, as destination.
Started reset.

The construction of the USB drive finished at 23:41 UTC.  It now says to
remove the USB drive and restart the computer.  Here we go.

Failed, saying "A Required device isn't connected or can't be accessed.
(Error code 0xc000000e).  While I was typing this, the machine powered
down (the ultimate peek-a-boo message).

The system was totally dead as long as I rebooted using the default
path after the re-install, which put Windows Boot Manager first.  By
trial and error, I discovered I could boot into Xubuntu on the second
SSD by explicitly specifying it after an F12 jump into the BIOS, and
then I tried explicitly specifying the first SSD there and *cazart*,
I got into the Alienware Windows 11 re-install, which is now
reconfiguring itself.

Well, that worked, and now we're at the Alienware connect to WiFi.
And, it worked!

Downloading updates.  It says "Sit back and relax while the magic
happens."  I shudder in terror.

It's rebooting again.

Licence agreement: accepted.

Well, it kind of works.  I shall test it further to-morrow.  Fourteen
hours is enough for one day.


/me runs away


2023 September 22

Did a complete update of packages on the Linux side:
    sudo su
    apt-get update
    apt-get dist-upgrade
then the little dance we do to pick up package which have been "kept
back" for whatever reason.
   1. apt list --upgradable
   2. apt-get install 
   3. apt list --upgradable
   4. If packages remain, go to 2.
   5. apt-get autoclean
   6. apt-get update
   7. apt-get dist-upgrade

    apt-get install geany

The current boot configuration is to boot into Xubuntu by default
(item "ubuntu" is first in the boot menu in the BIOS.  To boot into
Windows 11, restart with F12 down, then click "Windows Boot Manager"
in the panel at the left of the BIOS configuration screen.

After booting into Windows, Windows update popped up and began
downloading and installing of a page and a half up updates to
Microsoft and Dell packages.

On the Settings/Windows Update page there is a button at the upper
right which variously says "Download and install all" or "Install
all".  It appears to do nothing.  You have to click on the "Download"
or "Install" links for the individual items in the list to get
anything going.  These have progress indicators that are useless they
stick at 0% or some small number for a long time and then jump all
the way to "Completed".

Well, it appears to have forgotten its Product Key to enable Windows
Pro.  Re-entered it from Settings/System/Activation.  It hangs in
Preparing for Upgrade, with an application modal dialog box blocking
access to Settings and no way to cancel.

Rebooted.  Hung for a long time in "Restarting", then booted into
Linux before I could catch it with F12.  Rebooted again.

This time, as soon as it came up in Windows, I closed the Settings/
Windows Update and Dell Recovery windows, then launched Settings/System/
Activation and tried the Product Key upgrade to Pro again.  This time
it didn't hang and quickly got to 10% in Preparing for upgrade,
then got stuck there for a while, ran up to 80%, and proceeded like
molasses from there.

It finally completed, the rebooted--into Linux.  Manually rebooted
back into Windows.  Now it came up in "Adding features".  Rebooted.
This time I caught it with F12 and sent it back to Windows.  Now it
came up with a Pro-looking screen background.  Settings/Activation
says it's Pro.

To run the Windows command prompt as Administrator, right click the
Start menu, then select "Terminal (Admin)".  There are other ways to
get there, but this is the easiest.

According to multiple documents, including:
the way you enable the multi-boot menu is to run the command:
    bcdedit /set {bootmgr} displaybootmenu yes
from the terminal in Administrator mode.  This doesn't work.  When you
try it, you get "The set command specified is not valid".

Windows Update, having been stuck for around an hour at 7% downloading
the "Cumulative Update for Windows 11", jumped to 70%, then staggered its
way to 100% over the next five minutes.  After some unknown amount of
time (I was otherwise occupied), it finally changed status to "Pending
restart" and displayed a "Restart now" button.  Pushed it.  It took
a long time to get to 19%, whereupon it rebooted.  Started counting
over from 0% after boot.  Got to 27% and rebooted again.  Picked up at
30% and ran to 100%, finally came up in login screen.

Launched Windows Update again.  This time it reports three failed
updates, all with "Download error":
    Dolby - SoftwareComponent
    Dolby - AudioProcessingObject
    intelliGo - Extension
Tried to retry individually: buttons did nothing.  Tried Retry All and
it cleared these and showed two new Microsoft updates, one of which it
began to install.  One of them wants a reboot.  Here we go again.

When reboot completed, Windows Update says "You're up to date".  Well,
that only took five hours.

Idiot Steam starts automatically whenever you boot into Windows 11,
then bashes you with a splash screen.  To disable:
launch Steam, select Steam/Settings/Interface and uncheck "Run Steam
when my computer starts".  While I was there, enabled 24 hour clock.

In order to add a Windows 11 boot item to the Linux Grub menu, proceed
as explained by:
On Linux, run:
which will search all discs and partitions and report any EFI boot
operating systems present.  For Windows 11, it might report something
    /dev/nvme0n1p1@/efi/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi
Now, find all of the discs and partitions on the system with:
    fdisk -l
Your Windows 11 EFI partition will show up like:
    Device              Start        End    Sectors  Size Type
    /dev/nvme0n1p1       2048    1026047    1024000  500M EFI System
Find the UUID of the EFI partition just located:
    blkid /dev/nvme0n1p1
    /dev/nvme0n1p1: LABEL="ESP" UUID="723C-D7AF" BLOCK_SIZE="512"
        TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="062e996e-7119-4136-9c3b-1ea33edf31a5"
Now edit /etc/grub.d/40_custom.  This is a pre-existing file intended
for locally-added Grub declarations.  Add the declaration for "Windows
    menuentry 'Windows 11' {
        search --fs-uuid --no-floppy --set=root 723C-D7AF
        chainloader (${root})/EFI/Microsoft/Boot/bootmgfw.efi
Rebuild Grub to add the entry:
You should now see the entry in the generated  /boot/grub/grub.cfg file.

To make Grub menu display on Linux and not go directly to boot, edit
/etc/default/grub and set:
This gives you 30 seconds to choose an alternative before it boots into
GRUB_DEFAULT.  After editing the file, you must run:
before rebooting.

Now, with all of that, we have achieved dual-boot into Windows 11 and
Xubuntu, both via EFI boot.  Here's how it works.  The BIOS is
configured to boot from SSD #1 as the highest priority item.  This is
the Linux installation, and has an EFI partition containing the Grub
boot loader.  The Grub configuration has been modified to add a
target, "Windows 11", with its EFI partition on SSD #1, specified via
the UUID determined above.

When you boot the machine, the BIOS loads the Linux Grub, which shows
the boot options menu.  From there you can proceed directly into Linux
(the default after 30 seconds), or select Windows 11, in which case it
invokes chainloader to load the Windows Boot Manager from the EFI
partition on SSD #0, which proceeds to load Windows 11.  This is all
insanely complicated and obscure compared to the old style using an
MBR boot loader that simply loads from different partitions, but, after
all the wasted time and suffering, does actually work.

Somewhere in this process, the Alienware restore handler says it
finished applying updates to all of their add-on software,  At least
it isn't popping up the restore progress window on every reboot.

    apt-get install net-tools
in order to get ifconfig.

    apt-get install openssh-server
to enable SSH logins.

Windows was getting the time wrong by one hour until I turned Daylight
Saving Time adjustment off and on again in Settings/Time & language/
Date & time.

Began re-installation of software installed before the destruction of
the RAID0 array and factory re-set of the Alienware Windows 11

Installed the base Cygwin installation from:
I installed it in the default of:
not knowing the horrors which may eventuate should I choose another
location.  Chose to download from mirror at:
Selected Default packages to install.  Allowed it to add icon to
desktop and start menu.

Installed Phoenix Firestorm viewer for Second Life.  After some fiddling
with settings, it seems to be working, including voice input and
output.  There was a scary pop-up about enabling voice access through
the firewall required to use voice.  I enabled it for private and
public networks and it seems to be working OK.

Downloaded Alienware Command Center Application, A00 from:
This is the Alienware software that controls "special effects" such as
keyboard backlights, etc.  This was pre-installed on the system but blown
away by the factory reinstall.  You have to reboot after the installation
is complete.

Over to the Linux side now.

Changed the uucp/10 group to wheel/10 in /etc/group and /etc/gshadow.

Created the new kelvin user with:
    adduser --home /home/kelvin --shell /bin/bash --uid 3099 --gid 10 kelvin
with the conventional password.  Edited /etc/passwd to add additional

I can now log into Roswell from Ragnar with a password.

Transferred ~/bin and ~/.ssh from Ragnar to Roswell.  I can now log in
from Ragnar without a password.

Trasferred ~/.bash_profile from Ragnar.  Logged out and back in and
confirmed the utilities in ~/bin are now on the PATH.

Installed our magical "super" utility in /bin.  I just copied the
binary from Ragnar.  I'll get around to transferring the source
in ~/linuxtools in the fullness of time, but it's just too convenient
to do without in the interim.

Added kelvin to the "sudo" group.  This provides a potentially
lifesaving backup if we can't obtain privilege with "super".

Set the conventional password on "root".  This, again, provides another
form of rescue in case of lockout.

Transferred the /root/.ssh directory from Ragnar to Roswell.  We can
now log in as root from Ragnar to Roswell and vice versa.  This will
be required for making remote backups.

Disabled the trackpad permanently in the Settings/Mouse and Touchpad

Set the Settings/Window Manager/Focus to "Focus follows mouse".

Disabled that infuriating snap/resize when you're moving a window
and it touches the top of the screen with:
    Settings Manager / Window Manager Tweaks / Accessibility /
        Automatically tile windows when moving toward the screen edge

Disabled the Settings/Screensaver/Lock Screen for account kelvin.

Installed the Chromium browser with:
    snap install chromium

Ran a "snap refresh" which updated Firefox.

Using Chromium, downloaded the current google_chrome_stable_current_amd64.deb
package for Google Chrome.  Installed with:
    dpkg -i google_chrome_stable_current_amd64.deb

Disable touchpad is by-account.  Had to disable it on the kelvin account
as well as installation.

Set Fourmilab as home page in both Chrome and Chromium.

At this point, the system is basically working on both the Windows 11
and Xubuntu sides.  There is a great deal to install and configure, but
much of this can be done on an on-demand basis.  I will feel a lot more
warm inside once I have a backup of both sides of the machine.  I will
make a standard Fourmilab mirror backup of the Linux partition in the
near future.  I need to research options for backing up the Windows
side, since Bacula backup is not available as I'm offsite and do not
have access to the Fourmilab backup server.

Tip: If you set your network connections in modern Windows to “metered”, it cuts a bunch of telemetry and avoids downloading large updates until you approve them. Highly recommended.

(You still have to turn off all the telemetry options that are exposed to users.)